summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenz Steinert2020-06-09 16:08:15 +0200
committerLorenz Steinert2020-06-09 16:08:15 +0200
commit3742735bcde0ee1ed22ce0e64d372580058dee3d (patch)
treecc10ebee305ed0c0e134315b0ae7ee5850b9cf6b /PKGBUILD
downloadaur-3742735bcde0ee1ed22ce0e64d372580058dee3d.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..179f235bb9c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lorenz Steinert <lsteinert@uraziel.de>
+
+pkgname=python-matrix-synapse-shared-secret-auth
+_name=${pkgname#python-}
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="Shared Secret Authenticator password provider module for Matrix Synapse"
+url="https://github.com/devture/matrix-synapse-shared-secret-auth"
+arch=('x86_64')
+license=('AGPL')
+makedepends=('python-setuptools')
+depends=('python' 'python-twisted')
+source=("https://github.com/devture/${_name}/archive/${pkgver}.tar.gz")
+sha256sums=("ebbd3bb6dea556c6cd1021fe67a3f9e852158e068660c62ca0381fa633b93e95")
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+}