summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLorenzo Cappelletti2020-05-05 08:34:15 +0200
committerLorenzo Cappelletti2020-05-06 07:17:33 +0200
commit0d864ecc6a54b0bc01f0eb5fec7b4325dfdfc720 (patch)
treec25721f08b3b75aef8a4927622a3f5723c8b4b21 /PKGBUILD
downloadaur-0d864ecc6a54b0bc01f0eb5fec7b4325dfdfc720.tar.gz
Initial version 0.0.13
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfea58e70727
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Lorenzo Cappelletti <lorenzo.cappelletti gmail.com>
+
+_pyname=mbed-os-tools
+pkgname=python-${_pyname}
+pkgver=0.0.13
+pkgrel=1
+pkgdesc="The tools to test and work with Mbed OS"
+arch=('any')
+url="https://developer.mbed.org"
+license=('Apache')
+depends=(
+ 'python'
+ 'python-pyserial'
+ 'python-requests'
+ 'python-intelhex'
+ 'python-prettytable'
+ 'python-fasteners'
+ 'python-appdirs'
+ 'python-junit-xml'
+ 'python-lockfile'
+ 'python-six'
+ 'python-colorama'
+ 'python-beautifulsoup4'
+)
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/ARMmbed/mbed-os-tools/archive/$pkgver.tar.gz")
+sha256sums=('a50772dfe1a3862897cb668452b846844a29a8c59503ddb3e95bcd59dab41e09')
+
+package() {
+ cd "$srcdir/${_pyname}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: