summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2018-09-14 09:51:19 +0200
committerRichard Neumann2018-09-14 09:51:19 +0200
commit6edf7597d29f0200cfa0a071ac4bdbdbdde2556d (patch)
tree8a443964f5dd86e6ebb246259efbf88e3097e76f /PKGBUILD
parentc5ab2b5ffc5c4c7029340dfc62d216f1c26197f0 (diff)
downloadaur-6edf7597d29f0200cfa0a071ac4bdbdbdde2556d.tar.gz
Migrated project to GitHub.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89d1a2a178e9..88d174b800a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,12 @@ pkgver=r142.30b3b0b
pkgrel=1
pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
arch=('any')
-url="https://gitlab.com/coNQP/${_pkgbase}"
+url="https://github.com/coNQP/${_pkgbase}"
license=('GPLv3')
-depends=('python' 'python-docopt' 'python-pyzmq')
+depends=('python' 'python-docopt')
makedepends=('git' 'python')
+provides=('mcipc-git')
+replaces=('mcipc-git')
source=("${_pkgbase}::git+${url}.git")
md5sums=('SKIP')
pkgdir='pkg'
@@ -17,7 +19,7 @@ srcdir='src'
pkgver() {
- cd "${_pkgbase}" || exit 1
+ cd "${_pkgbase}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}