summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2018-09-13 21:36:40 +0200
committerRichard Neumann2018-09-13 21:36:40 +0200
commita1f17fef35400cf4c29425452ccb68591b79898d (patch)
tree1e3ff4a625e5691d265d84b1d3031f483e9469e6 /PKGBUILD
downloadaur-a1f17fef35400cf4c29425452ccb68591b79898d.tar.gz
init.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c76db1b1171
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='mcipc-git'
+pkgname="python-${_pkgbase}"
+pkgver=r78.42fc903
+pkgrel=1
+pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
+arch=('any')
+url='https://gitlab.com/coNQP/mcipc'
+license=('GPLv3')
+depends=('python' 'python-docopt' 'python-pyzmq')
+makedepends=('git' 'python')
+source=("${_pkgbase}::git+${url}.git")
+md5sums=('SKIP')
+pkgdir='pkg'
+srcdir='src'
+
+
+pkgver() {
+ cd "${_pkgbase}" || exit 1
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}