summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjose17112018-01-08 00:50:26 +0100
committerjose17112018-01-08 00:50:26 +0100
commitc31a29b1d35e0191d312a1321fbd514be66ee060 (patch)
treee17b54d43913cf8d226409ebd280f8759a964cd3 /PKGBUILD
downloadaur-c31a29b1d35e0191d312a1321fbd514be66ee060.tar.gz
Initial commit (adopted from aur3)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e9f18612be4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jose Riha
+# Contributor: Jose M. Dana <dana.develop - gmail>
+
+pkgname=python-memprof
+pypiname=memprof
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="A memory profiler for Python. It logs and plots the memory usage of all the variables."
+arch=(any)
+url="http://jmdana.github.io/memprof/"
+license=('GPL')
+depends=("python-matplotlib" "cython")
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/m/memprof/memprof-$pkgver.tar.gz")
+md5sums=("f8a41a19e9bcb5c2a86373e95f252c6f")
+
+package() {
+ cd "$srcdir/$pypiname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+