summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-11-06 16:16:02 -0500
committerCarlos Aznarán Laos2022-11-06 16:16:02 -0500
commit36ec00abf5f1136514ad2e90d587199cb02ce87a (patch)
tree2b17b030d8f8e7bfe1e2dda556c54b5de94dcbac /PKGBUILD
parent7da21a3d057e055a4c474d1de700ff8b27cdc2e3 (diff)
downloadaur-36ec00abf5f1136514ad2e90d587199cb02ce87a.tar.gz
Bump version to 2022.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b9ddd35c1eb5..0dc0b560792f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_base=meshpy
pkgname=python-${_base}
pkgdesc="2D/3D simplicial mesh generator interface for Python (Triangle, TetGen, gmsh)"
-pkgver=2020.1
-pkgrel=4
+pkgver=2022.1.3
+pkgrel=1
arch=('x86_64')
url="https://documen.tician.de/${_base}"
license=(MIT)
@@ -15,20 +15,19 @@ validpgpkeys=('900A958D9A0ACA58B1468F2471AA298BCA171145') # Andreas Kloeckner
sha512sums=('SKIP')
build() {
- cd "${_base}"
+ cd ${_base}
python3 ./configure.py --python-exe=python3
make
}
check() {
- cd "${_base}"
+ cd ${_base}
local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
PYTHONPATH="${PWD}/build/lib.linux-${CARCH}-${_pyversion}:${PYTHONPATH}" python test/test_meshpy.py
}
package() {
- cd "${_base}"
- export PYTHONHASHSEED=0
+ cd ${_base}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}