summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-03-12 09:11:10 +0100
committerKlaus Alexander Seistrup2023-03-12 09:11:10 +0100
commitdea298e68c02d361952eb44096375f6b3c3c1960 (patch)
tree0b3c27bceec17d3f8e2a895132581ab13864ca17 /PKGBUILD
parent7dd937cbe80ebf92743c9c3d76492c075e9037e3 (diff)
downloadaur-dea298e68c02d361952eb44096375f6b3c3c1960.tar.gz
Switch to standards based (PEP 517) packaging
https://wiki.archlinux.org/title/Python_package_guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3323209d714..70c603375068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='python-metno-locationforecast'
_pkgname="${pkgname#python-}"
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python interface for the MET Norway Locationforecast/2.0 weather service'
arch=('any')
license=('MIT')
@@ -14,11 +14,12 @@ source=(
'setup-py.diff'
)
depends=(
- 'python'
'python-requests'
)
makedepends=(
- 'python-setuptools'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
)
provided=("$pkgname")
conflicts=("$pkgname" "$pkgname-git")
@@ -44,13 +45,13 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$pkgver" || exit 1
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$_pkgname-$pkgver" || exit 1
- python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"