summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-08-29 11:53:27 +0200
committerAlexander F Rødseth2017-08-29 11:53:27 +0200
commitd08f1855dc60b7f4cd5bf298701880906ae1a5d3 (patch)
tree0dc966bc164410f4551a1a9b9d5de928b3ebb1b0 /PKGBUILD
downloadaur-d08f1855dc60b7f4cd5bf298701880906ae1a5d3.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50259daecade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=python-midi
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='Feature-rich MIDI toolkit for Python'
+arch=('x86_64' 'i686')
+url='https://github.com/vishnubob/python-midi'
+license=('MIT')
+depends=('alsa-lib' 'python')
+makedepends=('python-setuptools' 'swig')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vishnubob/python-midi/archive/feature/python3.tar.gz")
+sha256sums=('1a77874594f27d7ccb2c26bbb936d5ad35fbffa037bb0088028556afaee887f8')
+
+build() {
+ cd "$pkgname-feature-python3"
+
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-feature-python3"
+
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:ts=2 sw=2 et: