summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexis Jeandeau2021-01-17 19:44:13 +0900
committerAlexis Jeandeau2021-01-17 19:46:48 +0900
commit360e0cb2dd40e8cbe023b2498d8affa667093293 (patch)
tree5aee8b547777175c1c3975295b7aff2bb19af20d /PKGBUILD
downloadaur-360e0cb2dd40e8cbe023b2498d8affa667093293.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3d9c7002903
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexis Jeandeau <alexis[dot]jeandeau[at]gmail[dot]com>
+
+pkgname=python-midi-git
+_gitname=python-midi
+pkgver=r50.fec80bd
+pkgrel=1
+pkgdesc="A feature-rich, hardware-independent MIDI toolkit for Python"
+arch=('i686' 'x86_64')
+url="https://github.com/aspiers/python-midi"
+license=('MIT')
+depends=('alsa-lib' 'python')
+makedepends=('git' 'python-setuptools' 'swig')
+source=('git+https://github.com/aspiers/python-midi')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+
+ # No tag, use the number of revisions since the beginning of the history
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ # License is MIT clause type and needs to be installed
+ # The fork doesn't have the license file, so retrieve it from upstream
+ wget "https://raw.githubusercontent.com/vishnubob/python-midi/master/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: