summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-03-09 13:15:06 -0600
committerLuis Martinez2022-03-09 13:15:06 -0600
commit1527529e5b7fb313238efe2be685255a2fe8a72c (patch)
tree5ac68371024d11adf93bcc254ca3aaa6b1bd53e0 /PKGBUILD
parentac7c556e145e1cdf3187a3957ace2ca31eb0f4c9 (diff)
downloadaur-1527529e5b7fb313238efe2be685255a2fe8a72c.tar.gz
update to 0.5.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33a183013088..eaa40d0c2287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Patrick Lühne <patrick-arch@luehne.de>
pkgname=python-miio
-pkgver=0.5.10
+pkgver=0.5.11
pkgrel=1
pkgdesc="Python library & console tool for controlling Xiaomi smart appliances"
url="https://github.com/rytilahti/python-miio"
@@ -27,17 +27,19 @@ makedepends=(
'python-build'
'python-installer'
'python-wheel'
+ 'python-pytest'
'python-sphinx'
'python-sphinx-click'
'python-sphinx_rtd_theme'
'python-sphinxcontrib-apidoc')
install=miio.install
+changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('5997b973ed9119b0f33ec532fbb90af81cab34e08bbcd3e23b23c0d041b57994712a026ef7f79d7ac242e8db685af4c09b833cd19eea289a5edf85f5717eed3d')
+sha512sums=('804029ffa10760d3563b9025e3a074e5622494562c412ef4a3d7d8b62e2bd01ac3f4ee65de1d271143196464355f58a38364460454ead647254989d6ff550b12')
build() {
cd "$pkgname-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
cd docs
PYTHONPATH=../ make man
}