summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Häggqvist2015-11-03 23:17:05 +0100
committerVictor Häggqvist2015-11-03 23:17:05 +0100
commit2aa67ccc7e95d5f6b0546f510755c65823c0e913 (patch)
tree3dc1d5f1875974603dbf14703513953fbb1c501b /PKGBUILD
downloadaur-2aa67ccc7e95d5f6b0546f510755c65823c0e913.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df44cafbc1a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Victor Häggqvist <aur a snilius d com>
+# https://github.com/victorhaggqvist/archlinux-pkgbuilds
+pkgname=python-misaka
+_pkgname=misaka
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="The Python binding for Sundown, a markdown parsing library."
+arch=('i686' 'x86_64')
+url="http://misaka.61924.nl/"
+license=('MIT')
+depends=('python')
+options=(!emptydirs)
+conflicts=('python-misaka-v1')
+source=("https://pypi.python.org/packages/source/m/misaka/misaka-${pkgver}.tar.gz")
+sha256sums=('336ef1381ab840046b7da9f95c4c28af17e636aed8dcfcf1efe972db05f73604')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: