summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeremy Gust2024-04-21 15:17:03 -0600
committerJeremy Gust2024-04-21 15:17:03 -0600
commitdb7a886adce767dd5abf8280b8c7b793c25566a6 (patch)
treecb3c16ccb4728cb57a5e01c3d8df54eb79b48a60 /PKGBUILD
parentdc02e6751179bf44b5d71dc37d02c2926f6c5ab8 (diff)
downloadaur-db7a886adce767dd5abf8280b8c7b793c25566a6.tar.gz
Updated to version 2.0.5, using slightly altered PKGBUILD from last v2 mistune package in extra
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 28 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a11664d2df5..97ab9779351d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,38 @@
-# Maintainer: kyrenaios <kyrenaios at protonmail dot com>
-pkgbase='python-mistune2'
+# Maintainer:Jeremy Gust <jeremy AT plasticsoup DOT net>
+# Contributor: kyrenaios <kyrenaios at protonmail dot com>
+# Contributor: Kyle Keen <keenerd@gmail.com>
+# Contributor: David Runge <dvzrv@archlinux.org>
+# Contributor: shmilee
pkgname=('python-mistune2')
-_module='mistune'
-pkgver='2.0.0a6'
+_pyname='mistune'
+pkgver=2.0.5
pkgrel=1
-pkgdesc="A sane Markdown parser with useful plugins and renderers (alpha v2 branch)"
+pkgdesc="A fast yet powerful Python Markdown parser with renderers and plugins"
+arch=('any')
url="https://github.com/lepture/mistune"
-conflicts=('python-mistune')
-provides=('python-mistune')
+license=('BSD-3-Clause')
depends=('python')
-makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('5747cbb16fb50cd2ddd25d44d93b2c414a3b75875f6d9d58be8afbae67234ec9')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('python-pytest')
+conflicts=('python-mistune')
+provides=("python-mistune=$pkgver")
+source=("https://github.com/lepture/mistune/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('ca1cb685e55550d8adc421cec1bb5359895e04bc80259eb0bdc5b554669758e92d3f10cdd4bd01a15ca9aeeca62f9c8813a14101db0281b9a93eeecbff496aa0')
+b2sums=('fbece6ecb32003b40772b5772eb0415d1ae3654a52625578ff92daa4ed8df38758a6e725ddda86b2f7848406942454e09e52dca6583444f03769bd4911a4c5aa')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd $_pyname-$pkgver
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
+
+check() {
+ cd $_pyname-$pkgver
+ pytest -vv
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd $_pyname-$pkgver
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/$pkgname/"
+ install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/$pkgname/"
}