summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchrisjbillington2019-11-17 22:25:35 -0500
committerchrisjbillington2019-11-17 22:25:35 -0500
commitfa51fd20dbf52f0ce5f55a2b0c459990850000eb (patch)
tree2b4d5cf6d1e0b53d95788f29b176dbcd82ed1cbf /PKGBUILD
downloadaur-fa51fd20dbf52f0ce5f55a2b0c459990850000eb.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7871df2339d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer : Chris Billington <chrisjbillington@gmail.com>
+pkgname=python-mkl-fft-bin
+_pkgname=mkl_fft
+pkgver=1.0.15
+_build=py38ha843d7b_0
+pkgrel=1
+pkgdesc="Fast Fourier Transform using Intel MKL - prebuilt binaries from Anaconda"
+arch=('x86_64')
+url="https://github.com/IntelPython/mkl_fft"
+license=('custom')
+provides=('python-mkl-fft')
+conflicts=('python-mkl-fft')
+depends=('python-mkl-service' 'python-numpy')
+source=("http://repo.continuum.io/pkgs/main/linux-64/${_pkgname}-${pkgver}-${_build}.tar.bz2")
+sha256sums=('ad24e954606f5183d31cc99b20c86d878963c5a75626815cfc056c266ccbb55d')
+
+package() {
+ mkdir -p "${srcdir}/usr/"
+ mkdir "${pkgdir}/usr"
+ cp -drp --no-preserve=ownership "${srcdir}/lib" "${pkgdir}/usr/lib"
+ install -D -m 644 "${srcdir}/info/licenses/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file