summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2022-04-08 14:44:04 +0800
committerlilac2022-04-08 14:44:04 +0800
commitb983a1691a34d031a096fadf7441e80c12912911 (patch)
tree2ab76f97374aac24f0e6802e05c38adcb6041bfc /PKGBUILD
parent3f6a11c8461fa72fbdad2fbb9aada8b63ebbb9e7 (diff)
downloadaur-python-mmclassification-git.tar.gz
[lilac] updated to 0.22.0.r2.5a67bc8a-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bbb74a48a7f..4428b58a11e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=mmclassification
pkgname=python-mmclassification-git
-_pkgver=0.1.0
-pkgver=0.1.0.r458.894a82ea
+pkgver=0.22.0.r2.5a67bc8a
pkgrel=1
pkgdesc='OpenMMLab Image Classification Toolbox and Benchmark'
arch=('any')
url='https://github.com/open-mmlab/mmclassification'
license=('Apache')
depends=(
+ python-matplotlib
python-mmcv
python-numpy
python-pytorch
@@ -18,6 +18,12 @@ makedepends=(
git
python-setuptools
)
+optdepends=(
+ python-albumentations
+ python-colorama
+ python-requests
+ python-rich
+)
provides=(python-mmclassification)
conflicts=(python-mmclassification)
source=("${_pkgname}::git+https://github.com/open-mmlab/mmclassification.git")
@@ -25,7 +31,7 @@ sha512sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')" | sed "s/^v//"
}
build() {