summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbitwave2017-12-27 13:31:38 +0100
committerbitwave2017-12-27 13:31:38 +0100
commit7227665488c6a750f8e199fb4749ad4a193b6c3e (patch)
treeb76925d3dcb9999f38934b486cc4f4d5af19da56 /PKGBUILD
parent81087862c0deb2f15b6e8db82fa2a3e40ad837cf (diff)
downloadaur-7227665488c6a750f8e199fb4749ad4a193b6c3e.tar.gz
fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6804ac5f7a5e..0e74fec053a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,24 @@
-_pkgname=monkeytype
-pkgname=python-${_pkgname}
-pkgver=17.12.3
+pkgbase=('python-monkeytype')
+pkgname=('python-monkeytype')
+_module='MonkeyType'
+pkgver='17.12.3'
pkgrel=1
-pkgdesc="A system for Python that generates static type annotations by collecting runtime types"
-arch=('any')
-url="https://github.com/Instagram/MonkeyType"
-license=("BSD")
+pkgdesc="Generating type annotations from sampled production types"
+url="https://github.com/instagram/MonkeyType"
+depends=('python' 'python-retype' 'python-typed-ast')
makedepends=('python-setuptools')
-depends=('python')
-optdepens=()
-provides=('python-monkeytype-git')
-conflicts=('python-monkeytype-git')
-source=(https://github.com/Instagram/MonkeyType/archive/v${pkgver}.tar.gz)
-sha256sums=('c7a1c9ec3d0db124136835652496db16af8013ab3eefc737eca1c04d9c26f039')
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/m/monkeytype/MonkeyType-${pkgver}.tar.gz")
+sha256sums=('19d2061267c694ff6722ee28842f7b66c0dd1c0109b297167b750dc9e846a649')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
package() {
- cd "${srcdir}/MonkeyType-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}