summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbitwave2017-12-27 13:19:52 +0100
committerbitwave2017-12-27 13:19:52 +0100
commit81087862c0deb2f15b6e8db82fa2a3e40ad837cf (patch)
treec583b3376682d5013a788f8467509b2736022948 /PKGBUILD
downloadaur-81087862c0deb2f15b6e8db82fa2a3e40ad837cf.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6804ac5f7a5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+_pkgname=monkeytype
+pkgname=python-${_pkgname}
+pkgver=17.12.3
+pkgrel=1
+pkgdesc="A system for Python that generates static type annotations by collecting runtime types"
+arch=('any')
+url="https://github.com/Instagram/MonkeyType"
+license=("BSD")
+makedepends=('python-setuptools')
+depends=('python')
+optdepens=()
+provides=('python-monkeytype-git')
+conflicts=('python-monkeytype-git')
+source=(https://github.com/Instagram/MonkeyType/archive/v${pkgver}.tar.gz)
+sha256sums=('c7a1c9ec3d0db124136835652496db16af8013ab3eefc737eca1c04d9c26f039')
+
+package() {
+ cd "${srcdir}/MonkeyType-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}