summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán2024-02-27 10:21:12 -0500
committerCarlos Aznarán2024-02-27 10:21:12 -0500
commitc8e1913b4b06c087effd3a3a091a2f40658968b0 (patch)
tree854a5e3b701996f646fa5a2485c05bbbc14aad93 /PKGBUILD
parent870cf207441fa47190c7c55a1eb10bba940ab39a (diff)
downloadaur-c8e1913b4b06c087effd3a3a091a2f40658968b0.tar.gz
Bump version to 2024.2.26
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 232a1b70988d..0d9a86a4ae50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,17 @@
_base=monty
pkgname=python-${_base}
pkgdesc="Missing complement to Python"
-pkgver=2024.2.2
+pkgver=2024.2.26
pkgrel=1
arch=(x86_64)
url="https://github.com/materialsvirtuallab/${_base}"
license=(MIT)
depends=(python)
makedepends=(python-build python-installer python-setuptools python-wheel)
-checkdepends=(python-pytest python-bson python-pandas python-pydantic python-ruamel-yaml python-tqdm python-pytorch)
+checkdepends=(python-pytest python-bson python-pandas python-pydantic
+ python-ruamel-yaml python-tqdm python-pytorch)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('18cb86b92423316c35af9e2a1c13eb359946bf07136fd89b3a749cdf0bd79907d0ae4b7fa28d2366d379656d14c8ff1a4cb4ec395a17b1b3a607d2d3d999f5f9')
+sha512sums=('c25b41b448db5e8750e4d29a070bbcde7131bba1037780f3bf9df69c5d92a71704b86066d866ac616621b9adc8c9731004334fcb301f6675667dc9c80726a934')
build() {
cd ${_base}-${pkgver}
@@ -22,7 +23,7 @@ check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
- test-env/bin/python -m pytest tests -k 'not reverse_readfile_gz and not Path_objects and not zopen and not zpath'
+ test-env/bin/python -m pytest tests
}
package() {