summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJörg Thalheim2015-06-11 15:44:01 +0200
committerJörg Thalheim2015-06-11 15:44:01 +0200
commit4faca21f7d8cc1b88ae600669516d5fb9feb3d16 (patch)
tree73d10585192fd8911936acb722dc2e8e03f7f6be /PKGBUILD
downloadaur-python-mpd2-git.tar.gz
Initial Import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..488b272cfdd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jörg Thalheim <joerg@higgsboson.tk
+# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Peter Richard Lewis <plewis@aur.archlinux.org>
+# Contributor: Wieland Hoffmann <the_mineo@web.de>
+# Contributor: stonecrest <stonecrest[at]gmail[dot]com>
+
+pkgname='python-mpd2-git'
+pkgrel=1
+pkgver=20130625
+pkgdesc="Python MPD client library"
+depends=('python')
+conflicts=('python-mpd2')
+provides=('python-mpd2')
+url="http://github.com/Mic92/python-mpd2"
+makedepends=('git' 'python-distribute')
+license=('GPL3')
+arch=('any')
+sha1sums=('SKIP')
+source=("git+https://github.com/Mic92/python-mpd2.git")
+
+pkgver() {
+ cd "$srcdir/python-mpd2"
+ git log -1 --format='%cd' --date=short | tr -d -- '-'
+}
+
+package() {
+ cd "$srcdir/python-mpd2"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}