summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGerman L. Osella Massa2015-10-04 19:06:43 -0300
committerGerman L. Osella Massa2015-10-04 19:06:43 -0300
commit91236ca22d87bc65b43d2741d6f6e3516a22e38f (patch)
treecea7baa2edf8a9029c13fdd4191901237cb5cd69 /PKGBUILD
downloadaur-91236ca22d87bc65b43d2741d6f6e3516a22e38f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bc37cd83360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Submitter: Germán Osella Massa <gosella@gmail.com>
+
+pkgname=('python-mpld3' 'python2-mpld3')
+pkgver=0.2
+pkgrel=1
+pkgdesc='D3 Viewer for Matplotlib'
+arch=('any')
+url='http://mpld3.github.io/'
+license=('BSD 3-clause')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("http://pypi.python.org/packages/source/m/mpld3/mpld3-$pkgver.tar.gz")
+md5sums=('266f4e51a094f8ff1aaf7e2018f763b4')
+
+package_python-mpld3() {
+ depends=('python' 'python-matplotlib' 'python-jinja')
+
+ cd "$srcdir/mpld3-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-mpld3() {
+ depends=('python2' 'python2-matplotlib' 'python2-jinja')
+
+ cd "$srcdir/mpld3-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: