summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-21 19:10:52 +0700
committerAchmad Fathoni2022-03-21 19:10:52 +0700
commitd3f45fbae5be3076123f218ffbd8181a269b3471 (patch)
tree10f4329914231e6cda26def5c0e61446dc26b162 /PKGBUILD
downloadaur-d3f45fbae5be3076123f218ffbd8181a269b3471.tar.gz
13.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fed213776ebb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-mplfinance
+_pkgname=${pkgname:7}
+pkgver=0.12.8b9
+pkgrel=1
+pkgdesc="Utilities for the visualization, and visual analysis, of financial data"
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('BSD')
+makedepends=(python-build python-installer python-wheel)
+depends=(python)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('7e5adc924ca044620b1aeabd88a85209cacc56b6ddaf376f3ce0492c0cb1434c')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}