summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredfish2020-05-23 22:25:58 -0400
committerredfish2020-05-23 22:25:58 -0400
commit23496107e46ae1b849a16a644e3f51299f486d28 (patch)
treea618087e09f3ca92f6ec16db1bf94b9e26cf0618 /PKGBUILD
downloadaur-23496107e46ae1b849a16a644e3f51299f486d28.tar.gz
0.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6f9a51601be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-multicodec
+_name=py-multicodec
+pkgver=0.2.1
+pkgrel=1
+pkgdesc="A self-describing multiformat, wraps other formats with self-description."
+arch=('any')
+url="https://pypi.python.org/pypi/py-multicodec"
+license=('MIT')
+depends=('python'
+ 'python-setuptools'
+ )
+checkdepends=()
+source=("https://pypi.io/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('83021ffe8c0e272d19b5b86bc5b39efa67c8e9f4735ce6cafdbc1ace767ec647')