summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorclintval2017-12-19 18:07:52 -0500
committerclintval2017-12-19 18:07:52 -0500
commita18cf3054fe55591a07b9bf4a113c5ad04582a30 (patch)
treebf2956d382693bbc066dc955cb635d352e286fee /PKGBUILD
downloadaur-a18cf3054fe55591a07b9bf4a113c5ad04582a30.tar.gz
First commit with PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..278e768596c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-multiqc'
+pkgver=1.3
+pkgrel=1
+pkgdesc="Aggregate results from bioinformatics analyses across many samples into a single report"
+arch=('x86_64')
+url="https://github.com/ewels/MultiQC"
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=(
+ 'python'
+ 'python-click'
+ 'python-future>0.14.0'
+ 'python-jinja>=2.9'
+ 'python-lzstring'
+ 'python-markdown'
+ 'python-matplotlib'
+ 'python-networkx<2'
+ 'python-numpy>=1.9.2'
+ 'python-requests'
+ 'python-simplejson'
+ 'python-spectra'
+ 'python-yaml')
+provides=('python-multiqc')
+conflicts=('python-multiqc')
+options=(!emptydirs)
+source=("https://github.com/ewels/MultiQC/archive/v${pkgver}.tar.gz")
+md5sums=('67c4aae8b85ae40fcb2e98319fb629ac')
+
+package() {
+ cd "${srcdir}/MultiQC-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}