summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Botting2017-01-13 10:49:26 +1100
committerAndy Botting2017-01-13 10:51:52 +1100
commita2f8d5dc3d0466fb178a0f307549c39fd5c638d0 (patch)
treebdb9146fe8a468d52805e66a358fc9477200e624 /PKGBUILD
downloadaur-a2f8d5dc3d0466fb178a0f307549c39fd5c638d0.tar.gz
Initial commit of python-muranoclient
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec4bf928a3b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Andy Botting <andy@andybotting.com>
+
+pkgname=('python-muranoclient' 'python2-muranoclient')
+pkgver='0.11.1'
+pkgrel='1'
+pkgdesc='Python client library for Murano'
+arch=('any')
+url='http://docs.openstack.org/developer/python-muranoclient'
+license=('Apache')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("git+https://git.openstack.org/openstack/python-muranoclient#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cp -a python-muranoclient{,-py2}
+}
+
+build() {
+ cd "$srcdir"/python-muranoclient
+ python setup.py build
+
+ cd "$srcdir"/python-muranoclient-py2
+ python2 setup.py build
+}
+
+package_python-muranoclient() {
+ depends=('python-pbr' 'python-prettytable' 'python-glanceclient' 'python-keystoneclient'
+ 'python-iso8601' 'python-babel' 'python-pyopenssl' 'python-requests'
+ 'python-yaml' 'python-yaql' 'python-osc-lib' 'python-oslo-serialization'
+ 'python-oslo-utils' 'python-oslo-i18n')
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+
+package_python2-muranoclient() {
+ depends=('python-pbr' 'python-prettytable' 'python-glanceclient' 'python-keystoneclient'
+ 'python-iso8601' 'python-babel' 'python-pyopenssl' 'python-requests'
+ 'python2-yaml' 'python-yaql' 'python-osc-lib' 'python-oslo-serialization'
+ 'python-oslo-utils' 'python-oslo-i18n')
+ cd "${srcdir}/python-muranoclient-py2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+ mv "${pkgdir}"/usr/bin/murano{,2}
+}
+
+# vim:set ts=2 sw=2 et: