summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Brendel2018-10-30 02:40:51 -0700
committerChris Brendel2018-10-30 02:40:51 -0700
commit38189f29db6ab222803ff28fa25f6e55cdf9bd76 (patch)
tree7a35c03bde103411057ee19a957d6ff82d61074e /PKGBUILD
downloadaur-38189f29db6ab222803ff28fa25f6e55cdf9bd76.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3930a20124ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Chris Brendel <cdbrendel@gmail.com>
+# Python package author: Matthew Honnibal <matt@explosion.ai>
+pkgname=python-murmurhash
+_origpkgname=murmurhash
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Cython bindings for MurmurHash2"
+arch=("x86_64")
+url="https://github.com/explosion/murmurhash"
+license=("MIT")
+depends=("python" "cython" "python-pytest")
+makedepends=("python-setuptools" "python-wheel")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/murmurhash/archive/v$pkgver.tar.gz")
+md5sums=("35a01f10802226e2d99e463004f520ec")
+
+package() {
+ cd "$_origpkgname-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}