summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartino Pilia2022-11-05 18:53:50 +0100
committerMartino Pilia2022-11-05 18:53:50 +0100
commita2795a5e8227f65fbf0b0d21294d377200a9e115 (patch)
tree9f8d43e3386c1bde3388c5a2dd6ec151653fa9b2 /PKGBUILD
parent4f941effa7fc0ec6a15909ec32db9297928abfe7 (diff)
downloadaur-python-music21.tar.gz
Version 8.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29ded4b51db7..75b3264b5ddc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martino Pilia <martino.pilia@gmail.com>
_pkgname=music21
pkgname=python-$_pkgname
-pkgver=7.3.0
+pkgver=8.1.0
pkgrel=1
pkgdesc="A toolkit for computer-aided musical analysis"
arch=('any')
@@ -11,6 +11,7 @@ depends=(
'python-chardet'
'python-joblib'
'python-more-itertools'
+ 'python-requests'
'python-webcolors'
)
optdepends=(
@@ -22,9 +23,19 @@ optdepends=(
'python-pygame: allows realtime MIDI performance with music21.midi'
'python-scipy: faster FFT for music21.audioSearch'
)
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-build'
+ 'python-hatchling'
+ 'python-installer'
+ 'python-wheel'
+)
source=("https://github.com/cuthbertLab/music21/archive/v${pkgver}.tar.gz")
-sha256sums=('a2cfd7648339bf039da4a2569882e6cd43e4af6c91d3858d9d4909b702a1e53d')
+sha256sums=('0fd00078fd9bfcc4f0c6e36d44fd6e5bb5b8506c6acba3796941b568a2cf64ad')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -33,5 +44,5 @@ package() {
"${srcdir}/$_pkgname-$pkgver/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python setup.py install --optimize=1 --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}