summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Nelson2021-06-19 17:20:18 -0400
committerPhilip Nelson2021-06-19 17:20:18 -0400
commit31ea80b122268d65c91cb4155a1916aeadc7eba6 (patch)
tree1e510f3cb410981fbf3516a3d8e9a6450a7bd092 /PKGBUILD
downloadaur-31ea80b122268d65c91cb4155a1916aeadc7eba6.tar.gz
first commit adding .SRCIFNO and MAKEPKG
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfb08313355e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Philip Nelson <7PMNelson@gmail.com>
+_pkgname=mwcleric
+pkgname=python-mwcleric-git
+pkgdesc="A library is a client for connecting to, and occasionally editing, the Fandom/Gamepedia esports wikis"
+pkgver=0e94b5c
+pkgrel=1
+arch=('any')
+url="https://github.com/RheingoldRiver/mwcleric"
+license=('MIT')
+depends=('python' 'python-mwparserfromhell' 'python-pytz' 'python-mwclient')
+makedepends=('git' 'python-setuptools')
+source=('git://github.com/RheingoldRiver/mwcleric')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --tags --always | sed 's|^v||;s|\([^-]*-g\)|r\1|;s|-|.|g'
+}
+
+build() {
+ cd "$_pkgname"
+ python setup.py build
+}
+
+check() {
+ cd "$_pkgname"
+ python setup.py test
+}
+
+package() {
+ cd "$_pkgname"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+