summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoramadejpapez2022-11-18 18:51:56 +0100
committeramadejpapez2022-11-18 18:51:56 +0100
commitad5cf8d03a9bdff8bf42184df6c8e2c825041b3e (patch)
treea55dc3bd324d46e03ad136cc449b19329900d6c7 /PKGBUILD
parent543801c90cc7cc1454c82d3f6d2111eb34ceee8b (diff)
downloadaur-ad5cf8d03a9bdff8bf42184df6c8e2c825041b3e.tar.gz
try to go away from python-dephell
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d5f55b34c46..3a64f5460102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=("any")
url="https://github.com/HashPals/Name-That-Hash"
license=("GPL3")
depends=("python" "python-click" "python-rich")
-makedepends=("python-setuptools" "python-dephell")
+makedepends=("python-build" "python-installer" "python-poetry-core")
source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=("2f8dd4beaf7326d2f664f18205c024848dcb627ff29ceffb22ab410fbef2d761")
@@ -19,12 +19,12 @@ prepare() {
}
build() {
- cd "$_pkgname-$pkgver"
- python setup.py build
+ cd $_pkgname-$pkgver
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --prefix="/usr" --root="$pkgdir/" --optimize=1 --skip-build
+ cd $_pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}