summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco A Rojas2021-09-12 09:47:39 -0500
committerMarco A Rojas2021-09-12 09:47:39 -0500
commit9ab53b096f68c0f758e285a2115c393f1fb29cd5 (patch)
tree49d027204ab96b951b88d9876c365313bdf147ed /PKGBUILD
downloadaur-9ab53b096f68c0f758e285a2115c393f1fb29cd5.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d02df28a29ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marco A Rojas <marco.rojas@zentek.com.mx>
+
+pkgbase='python-nbtermix'
+pkgname=('python-nbtermix')
+_module='nbtermix'
+pkgver='0.1.2'
+pkgrel=1
+pkgdesc="Fork of nbterm. Jupyter Notebooks in Your terminal."
+url="https://github.com/mtatton/nbterm"
+depends=('python' 'python-rich')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('5c0568311cecf0992e0c2f80fea028c969bf877181481fa040bea442449d13c2')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/python-nbtermix/LICENSE"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}