summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergio2021-03-25 14:38:38 +0000
committerSergio2021-03-25 14:38:38 +0000
commita3fb9a2e2589af0db6e5fd369621eb8f5d9bd854 (patch)
tree46ad8287bdf1981aeb6a8682c87058a41d6a5ec2 /PKGBUILD
parent325ae7ce6dd065c34107ab9c559052e02a7986f7 (diff)
downloadaur-a3fb9a2e2589af0db6e5fd369621eb8f5d9bd854.tar.gz
updating to version 0.9.0 and dropping support for python 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65ce2057f38b..7dd7965c59fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
# Contributor: mcgyver <newsletter.sergio@gmail.com>
pkgbase=python-neo
-pkgname=('python-neo' 'python2-neo')
+#pkgname=('python-neo' 'python2-neo')
+pkgname=('python-neo')
_name=${pkgbase#python-}
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Neo is a package for representing electrophysiology data in Python, together with support for reading a wide range of neurophysiology file formats"
arch=('any')
url="https://pypi.org/project/neo/#files"
license=("custom")
-depends=("python-quantities" "python-setuptools" "python2-setuptools")
+#depends=("python-quantities" "python-setuptools" "python2-setuptools")
+conflicts=("python2-neo")
+depends=("python-quantities" "python-setuptools")
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('SKIP')
+sha256sums=('6e31c88d7c52174fa2512df589b2b5003e9471fde27fca9f315f4770ba3bd3cb')
package_python-neo() {
depends+=('python' 'python-numpy')
@@ -21,9 +24,9 @@ package_python-neo() {
python setup.py install --root="${pkgdir}"
}
-package_python2-neo() {
- depends+=('python2' 'python2-numpy')
-
- cd "${srcdir}/${_name}-${pkgver}"
- python2 setup.py install --root="${pkgdir}"
-}
+#package_python2-neo() {
+# depends+=('python2' 'python2-numpy')
+#
+# cd "${srcdir}/${_name}-${pkgver}"
+# python2 setup.py install --root="${pkgdir}"
+#}