summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxr19982019-02-06 19:21:02 +0100
committerMaxr19982019-02-06 19:21:02 +0100
commitf989fa68bcac555cb7a86fcb49aa2727dca692ed (patch)
treeea70929c48b1dc93bc2d495ecfa388e19e48d12a /PKGBUILD
downloadaur-f989fa68bcac555cb7a86fcb49aa2727dca692ed.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ae85a93af7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Maxr1998 <max.rumpf1998@gmail.com>
+
+_name=netdisco
+pkgname=python-netdisco
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Library for Python that discovers devices on your local network'
+arch=('any')
+url=https://github.com/home-assistant/netdisco
+license=('Apache')
+depends=('python' 'python-zeroconf' 'python-requests' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/n/netdisco/$_name-$pkgver.tar.gz")
+sha256sums=("2571fc094f3bf8c60be211e90474515f565f3ef1c92e857176daab8577493a3b")
+
+build() {
+ cd $_name-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $_name-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: