summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsudokode2015-06-08 20:50:03 -0400
committersudokode2015-06-08 20:50:03 -0400
commit26c9d0cd01c3381a64620909839983c3dc7de161 (patch)
tree0fb0cd328eed73f77e12bdd056558b549ef30183 /PKGBUILD
downloadaur-26c9d0cd01c3381a64620909839983c3dc7de161.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47af42280d15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: sudokode <sudokode@gmail.com>
+
+pkgname=python-netifaces-git
+pkgver=1.0.0.r6.098dfda
+pkgrel=1
+pkgdesc="Portable module to access network interface information in Python 3"
+arch=('i686' 'x86_64')
+url="https://github.com/kelleyk/py3k-netifaces"
+license=('MIT')
+depends=('python')
+makedepends=('git' 'python-distribute')
+source=("$pkgname::git://github.com/kelleyk/py3k-netifaces.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+
+ echo "1.0.0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $pkgname
+
+ python setup.py install --root "$pkgdir"
+
+ install -Dm644 README "$pkgdir"/usr/share/python-netifaces/README
+ install -Dm644 README "$pkgdir"/usr/share/licenses/python-netifaces/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: