summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Borders2019-11-26 14:43:42 -0500
committerMichael Borders2019-11-26 14:43:42 -0500
commite7bd12779534b84d3539526cab3c1a309cc3acab (patch)
tree20e0aaf21af2a828889c0d5e762e9b7c746beea4 /PKGBUILD
parente7a2f22fdd5ce2ce8957107682b5f856b4397990 (diff)
downloadaur-e7bd12779534b84d3539526cab3c1a309cc3acab.tar.gz
Added check() function
At the moment two depdencies for testing are not python3.8 compatible, so package checking is disabled.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72e739bc2742..4510f7eb45bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,16 @@ url="https://github.com/ktbyers/netmiko"
license=('MIT')
depends=('python' 'python-paramiko' 'python-scp' 'python-pyserial' 'python-textfsm')
makedepends=('python-setuptools')
+#checkdepends=('python-tox')
source=("${url}/archive/${_pkgver}.tar.gz")
sha256sums=('02f6d1eafa5588ae89a7ba01f9a0c65089aded8cfedef7bd8d61a1255bf2b4f7')
+# Tests fail on python3.8 as two testing depends are not compatible yet.
+#check() {
+# cd "$srcdir/$_pkgname-$pkgver"
+# tox test -e py
+#}
+
package(){
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1