summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorandalenavals2018-01-05 23:30:36 -0500
committerandalenavals2018-01-05 23:30:36 -0500
commit50329eb595951c60aa6593646276f63f0088240b (patch)
tree51f6e400bacd25f8397887ddc4a4176ae3b0a40b /PKGBUILD
downloadaur-50329eb595951c60aa6593646276f63f0088240b.tar.gz
Still the check() function is a issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f28d56fb418
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+_pkgname=python-ngmix
+pkgbase=python-ngmix-git
+pkgname=("python-ngmix-git" "python2-ngmix-git")
+pkgver=v0.9.4.r1.3a0e7ce
+pkgrel=1
+pkgdesc=" Gaussian mixture models and other code for working with for 2d images, implemented in python "
+arch=('x86_64')
+url="https://github.com/esheldon/ngmix"
+license=('GPL')
+checkdepends=('make')
+makedepends=('git' 'python' 'python-numpy' 'python2' 'python2-numpy' )
+source=("${_pkgname}::git+${url}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cp -a $_pkgname{,-py2}
+}
+
+build() {
+ cd "$srcdir"/$_pkgname
+ python setup.py build
+
+ cd "$srcdir"/$_pkgname-py2
+ python2 setup.py build
+}
+
+check() {
+ cd "$srcdir"/$_pkgname/test
+ make test/test-gmix test/test-gmix-model test/test-fastexp test/test-fastexp-speed test/test-image test/test-shape
+ ./test/test-gmix
+ ./test/test-gmix-model
+ ./test/test-fastexp
+ ./test/test-fastexp-speed
+ ./test/test-image
+ ./test/test-shape
+}
+
+package_python-ngmix-git() {
+ depends=('python')
+ cd "${_pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+
+}
+
+package_python2-ngmix-git() {
+ depends=('python2')
+ cd "${_pkgname}"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+
+}
+