summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-25 14:09:50 -0500
committerCarlos Aznarán Laos2022-10-25 14:09:50 -0500
commit14f2d71c49eb0b1d99b0e3cf321f30bf2e8ce8b3 (patch)
treeb0d74ee3132a61dd8bb2c2d4026e63f374e20c36 /PKGBUILD
parent9362d5ca350edf3094b26c07e33c75f1cbebdaf7 (diff)
downloadaur-14f2d71c49eb0b1d99b0e3cf321f30bf2e8ce8b3.tar.gz
Change python-install by python-installer
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 323f79dd02d9..c261f92d1666 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/firefly-cpp/${_base}"
arch=(any)
license=(MIT)
depends=(python-niapy python-nltk)
-makedepends=(python-build python-install python-poetry-core)
+makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
sha512sums=('bb608a9c52d727975770d00fc07ea4f3ebdd97fb36b6fc750362d3cd79814eb60440584c3232cca40c3bf704b678c29e5e511cee6048164f8abf94a91c2d43a3')
@@ -25,10 +25,7 @@ check() {
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
-
- # https://github.com/FFY00/python-install/pull/6
- chmod +x "${pkgdir}"/usr/bin/*
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")