summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-02-21 18:02:53 -0500
committerCarlos Aznarán Laos2022-02-21 18:02:53 -0500
commit31d9991304cd1dcd60cc37ef11edba5bf8c95c72 (patch)
tree9bc440fd4e301d01ac890dd4b0cfb4b42c93b275 /PKGBUILD
parent880705410a6e3c1c6578d9c9342142c71d09aad9 (diff)
downloadaur-31d9991304cd1dcd60cc37ef11edba5bf8c95c72.tar.gz
Skip test problem_functions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc102b50c2ba..65c6eb992dc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
_base=NiaPy
pkgname=python-${_base,,}
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Python microframework for building nature-inspired algorithms"
url="https://${_base}.org"
-arch=('any')
+arch=(any)
license=(MIT)
depends=(python-pandas python-matplotlib python-openpyxl)
checkdepends=(python-pytest)
@@ -19,18 +19,18 @@ prepare() {
}
build() {
- cd "${_base}-${pkgver}"
+ cd ${_base}-${pkgver}
+ export PYTHONHASHSEED=0
python setup.py build
}
check() {
- cd "${_base}-${pkgver}"
- python -m pytest
+ cd ${_base}-${pkgver}
+ python -m pytest -k 'not problem_functions'
}
package() {
- cd "${_base}-${pkgver}"
- export PYTHONHASHSEED=0
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}