summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiam Timms2023-02-03 09:58:19 -0500
committerLiam Timms2023-02-03 09:58:19 -0500
commit03070689ea11b2b9ef2187078bba578da80f3817 (patch)
treeddf168a2d1def2de53b57234260c97f0f7c135da /PKGBUILD
parentefdbaf50ad24c02f807e6cb7f55e34b71a4a8a71 (diff)
downloadaur-03070689ea11b2b9ef2187078bba578da80f3817.tar.gz
Updating using info from effigies on deps
changes from discussion here: https://github.com/nipy/nibabel/pull/1192#issuecomment-1415882725
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac83068e919a..cc077aef19a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,20 @@
# Contributor: wedjat <wedjat@protonmail.com>
# Contributor: Masoud <mpoloton@gmail.com>
-pkgname=python-nibabel
_pkgname=nibabel
+pkgname=python-$_pkgname
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
arch=('any')
url='http://nipy.org/nibabel'
license=('MIT')
depends=('python-numpy>=1.19'
- 'python-six>=1.3'
- 'python-setuptools'
- 'python-setuptools-scm')
-# building documentation may not work properly, since authors tell to use sphinx <=1.5.6, because "Sphinx >= 1.6 breaks the math_dollar extension"
-makedepends=('python-packaging'
- 'python-hatch-vcs'
- 'python-build'
+ 'python-packaging')
+makedepends=('python-hatch-vcs'
+ 'python-setuptools'
+ 'python-build'
'python-installer')
-# checkdepends=('python-pytest')
optdepends=('python-scipy: for full SPM-ANALYZE support'
'python-memory-profiler'
'python-fuse'