summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiam Timms2019-12-13 12:12:34 -0500
committerLiam Timms2019-12-13 12:12:34 -0500
commitb86b5524dc9b4fcdf16d9dcab390c458a0ef7a10 (patch)
treec718f482f1e64bdd195fd44d9e02a0d8acaeedba /PKGBUILD
parent480527a64eae66b51e7da7e380b68ebe04f96927 (diff)
downloadaur-b86b5524dc9b4fcdf16d9dcab390c458a0ef7a10.tar.gz
minor fixes to maintainer header, added dependency on python-six and updated arch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98c3c21fc98c..539beb753c27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
-# Maintainer: wedjat <wedjat@protonmail.com>
+# Maintainer: Thomas Roos <mail [at] thomasroos.nl>
+# Co-maintainer: Liam Timms <timms5000@gmail.com>
+# Contributor: wedjat <wedjat@protonmail.com>
# Contributor: Masoud <mpoloton@gmail.com>
pkgname=python-nibabel
pkgver=2.5.1
-pkgrel=1
+pkgrel=2
pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
-arch=('x86_64') #i686 not tested
+arch=('any')
url='http://nipy.org/nibabel/index.html'
license=('MIT' 'BSD')
-depends=('python' 'python-numpy>=1.12')
+depends=('python' 'python-numpy>=1.8' 'python-six>=1.3')
# building documentation may not work properly, since authors tell to use sphinx <=1.5.6, because "Sphinx >= 1.6 breaks the math_dollar extension"
makedepends=('python-setuptools') #('python-sphinx' 'python-numpydoc' 'python-matplotlib>=1.3')
# checkdepends=('python-nose' 'python-mock')
@@ -18,14 +20,14 @@ install=
source=("$pkgname-$pkgver.tar.gz::https://github.com/nipy/nibabel/archive/$pkgver.tar.gz")
sha512sums=('49de1a42113e64a56336e02f3143588b574c7b063b10b892ee125048451be701955e505bd1d51183327e2ee221f8364005fdd9fa7d256343113ab6ca1994820d')
-build()
+build()
{
cd "$srcdir/nibabel-$pkgver"
python setup.py build
}
-package()
+package()
{
cd "$srcdir/nibabel-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1