summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiam Timms2023-01-23 11:33:51 -0500
committerLiam Timms2023-01-23 11:33:51 -0500
commitc245400c24eb3f499279d9e6051d044d4bbd9351 (patch)
treeaaf588a7d4c91e484cfb375b60427205df63c5b9 /PKGBUILD
parentf3414c10c1673e502171eecdb899b8a7478daea5 (diff)
downloadaur-c245400c24eb3f499279d9e6051d044d4bbd9351.tar.gz
version bump, dependencies and build system change
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c4d4c807156b..a93fa83649ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,31 @@
pkgname=python-nibabel
_pkgname=nibabel
-pkgver=4.0.2
+pkgver=5.0.0
pkgrel=1
pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
arch=('any')
url='http://nipy.org/nibabel'
license=('MIT')
-depends=('python' 'python-numpy>=1.17' 'python-six>=1.3')
+depends=('python' 'python-numpy>=1.19' 'python-six>=1.3')
# building documentation may not work properly, since authors tell to use sphinx <=1.5.6, because "Sphinx >= 1.6 breaks the math_dollar extension"
-makedepends=('python-setuptools')
-# checkdepends=('python-nose' 'python-mock')
+makedepends=('python-setuptools' 'python-setuptools-scm' 'python-packaging' 'python-hatch-vcs')
+checkdepends=('python-pytest')
optdepends=('python-scipy: for full SPM-ANALYZE support' 'python-pydicom: for DICOM support' 'python-pillow: for PNG conversion in DICOMFS' 'python-h5py: for MINC2 support' 'python-indexed-gzip')
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/nipy/${_pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('71e1453ab897ef228062bbf9eae4430a0e89c024d110d68ac70414e4cdf02dafbbe3f0f640ef8b1adfe59c9171839d3f398b34b6bcd39aa4826960135187d3cd')
+sha512sums=('844d2ef7c04376068dcc8ac2daaa2842d2a06812c283bc97dd8fe6b0c6dfa03b03f4413e2061feefffcb257396e1481e4419cf82a0e108149cbdca1336e16e64')
build()
{
cd "$srcdir/${_pkgname}-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package()
{
cd "$srcdir/${_pkgname}-$pkgver"
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}