summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiam Timms2023-02-10 13:46:30 -0500
committerLiam Timms2023-02-10 13:46:30 -0500
commitf4e0e47c0f0786f7be25f74874a1a1303f00e8d1 (patch)
tree2d1c6b318158ac42b7b789ffda530446c10c746c /PKGBUILD
parent03070689ea11b2b9ef2187078bba578da80f3817 (diff)
downloadaur-f4e0e47c0f0786f7be25f74874a1a1303f00e8d1.tar.gz
Adding testing, fixing deps, switching source URL
Changes to reflect: https://github.com/nipy/nibabel/pull/1192#issuecomment-1416099825
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc077aef19a3..e5b553e007ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@
_pkgname=nibabel
pkgname=python-$_pkgname
pkgver=5.0.0
-pkgrel=3
+pkgrel=4
pkgdesc='Python library for reading and writing of some common neuroimaging file formats'
arch=('any')
url='http://nipy.org/nibabel'
license=('MIT')
depends=('python-numpy>=1.19'
- 'python-packaging')
+ 'python-packaging>=17'
+ 'python-setuptools')
makedepends=('python-hatch-vcs'
- 'python-setuptools'
'python-build'
'python-installer')
optdepends=('python-scipy: for full SPM-ANALYZE support'
@@ -24,8 +24,9 @@ optdepends=('python-scipy: for full SPM-ANALYZE support'
'python-pillow: for PNG conversion in DICOMFS'
'python-h5py: for MINC2 support'
'python-indexed-gzip: for faster reading of NIFTI files')
-source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/nipy/${_pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('844d2ef7c04376068dcc8ac2daaa2842d2a06812c283bc97dd8fe6b0c6dfa03b03f4413e2061feefffcb257396e1481e4419cf82a0e108149cbdca1336e16e64')
+checkdepends=('python-pytest-httpserver')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha512sums=('2275be8a6ef7a48d69dfc23c159da6afabde2c57bb50e6966c8ffd0d5cd7f73e9d81635c83ff910a302c8c7d8d394c023783357678c616e14a83b5996c109061')
build()
{
@@ -33,6 +34,12 @@ build()
python -m build --wheel --no-isolation
}
+check()
+{
+ cd "$srcdir/${_pkgname}-$pkgver"
+ pytest
+}
+
package()
{