summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiam Timms2020-06-04 18:09:14 -0400
committerLiam Timms2020-06-04 18:09:14 -0400
commitd8929d56bd221a263582fa1516cccc18055c40ec (patch)
tree71b2aa4a34694b9206b841c79866093297d682fe /PKGBUILD
parent578b9601b95506fc509335c80484a7c0630036c6 (diff)
downloadaur-d8929d56bd221a263582fa1516cccc18055c40ec.tar.gz
adding patch (see: https://github.com/nipy/nipype/issues/3223) and check function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 21 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc77654c210e..df255fd24e41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=python-nipype
_name=${pkgname/python-/}
pkgver=1.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='Neuroimaging in python pipelines and interfaces'
arch=('any')
url='https://github.com/nipy/nipype'
@@ -18,8 +18,9 @@ license=('Apache')
depends=('python-click' 'python-networkx' 'python-nibabel' 'python-numpy' 'python-packaging' 'python-prov' 'python-pydot' 'python-pydotplus' 'python-dateutil' 'python-rdflib>=5.0.0' 'python-scipy' 'python-simplejson' 'python-traits' 'python-filelock' 'python-matplotlib' 'python-numpydoc' 'python-future' 'python-funcsigs' 'python-pytest' 'python-mock' 'python-etelemetry>=0.2.0')
makedepends=('python-sphinx' 'python-sphinxcontrib-napoleon')
optdepends=('python-pybids' 'python-dipy' 'ants-git' '3dslicer' 'afni' 'freesurfer' 'fsl' 'spm12')
-source=("${_name}-${pkgver}.tar.gz::https://github.com/nipy/${_name}/archive/${pkgver}.tar.gz")
-sha256sums=('dbbe74ac99740da749350a6957326bd78d6ba388694b0c09cd92575f111576af')
+source=("${_name}-${pkgver}.tar.gz::https://github.com/nipy/${_name}/archive/${pkgver}.tar.gz" "0001-DOC-Skip-BIDSDataGrabber-doctest-if-pybids-is-missin.patch")
+sha256sums=('dbbe74ac99740da749350a6957326bd78d6ba388694b0c09cd92575f111576af'
+ '50dd1c4093399d05fdf0f6558f5d31ef6fdfd30771c23c54314e190e18a217d2')
_setpaths(){
@@ -44,6 +45,14 @@ _setpaths(){
}
+prepare() {
+
+ mv 0001-DOC-Skip-BIDSDataGrabber-doctest-if-pybids-is-missin.patch ${srcdir}/${_name}-${pkgver}
+ cd ${srcdir}/${_name}-${pkgver}
+
+ patch --forward --strip=1 --input=0001-DOC-Skip-BIDSDataGrabber-doctest-if-pybids-is-missin.patch
+}
+
build() {
@@ -55,6 +64,15 @@ build() {
}
+check() {
+
+ cd ${srcdir}/${_name}-${pkgver}
+
+ _setpaths
+ echo "MATLABCMD: ${MATLABCMD}"
+
+ pytest -v --doctest-modules nipype
+}
package() {