summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-03 22:41:32 +0300
committerCaleb Maclennan2023-05-03 22:41:32 +0300
commit95c4bb3eede90bdec9592d931139c09672a7c3f6 (patch)
tree092d61a3fb2b66e1e4e9b7ee6d752b902239767e /PKGBUILD
parent5ba5215a2582f8b67d0507d432cde0eb6b44cab5 (diff)
downloadaur-95c4bb3eede90bdec9592d931139c09672a7c3f6.tar.gz
upgpkg: python-ntfs 0.1.5-2
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5715215c4785..8afb336d1a54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,20 +10,21 @@ arch=(any)
url="https://github.com/sunshowers-code/$_pkgname"
license=(MIT)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_pkgname-$pkgver"
source=("$url/archive/$pkgver/$_archive.tar.gz")
sha256sums=('9a927a0821460bf3e3a9bfc0b3e23aa732f056aadbc5c116ebac6a6dca56f5c3')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
- local _py3_ver=$(python --version | cut -d " " -f2)
- rm -rf "$pkgdir/usr/lib/python${_py3_ver%.*}/site-packages/tests"
+ local _pyver=$(python --version | cut -d " " -f2)
+ rm -rf "$pkgdir/usr/lib/python${_pyver%.*}/site-packages/tests"
}