summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBlair Bonnett2023-03-14 23:17:19 +0100
committerBlair Bonnett2023-03-14 23:17:19 +0100
commit80d26b4504f05d75590ed2743959fdb9495e3eb2 (patch)
tree6c63de553214854a3702e44f0b52d71b8d62e781 /PKGBUILD
parentfed7693d0a9354977924948518bab4eb2925e87a (diff)
downloadaur-80d26b4504f05d75590ed2743959fdb9495e3eb2.tar.gz
PR8691 has now been merged into main
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 2 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64f2602eeb4c..066615c730f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Michael Schubert <mschu.dev at gmail>
pkgname=python-numba-git
-pkgver=0.57.0dev0.r1070.gfcdb0ee49.pr8691
+pkgver=0.57.0dev0.r1306.g26bc50198
pkgrel=1
pkgdesc='NumPy aware dynamic Python compiler using LLVM (Git version)'
url='https://github.com/numba/numba'
@@ -26,17 +26,9 @@ provides=("python-numba=$pkgver")
source=('git+https://github.com/numba/numba.git')
sha256sums=('SKIP')
-prepare() {
- cd numba
- git config --local user.name "makepkg"
- git config --local user.email "makepkg@localhost"
- git fetch origin refs/pull/8691/head:pr8691
- git merge --commit --no-edit pr8691
-}
-
pkgver() {
cd numba
- printf "%s.pr8691" "$(git describe --long origin/HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
+ printf "%s" "$(git describe --long origin/HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g')"
}
build() {