summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2016-02-19 13:23:26 +0100
committerSebastiaan Lokhorst2016-02-19 13:23:26 +0100
commitbc8c9bc5f3e1b3adea8731d81f3b32fea3c45f82 (patch)
treee388bd362eb9c6816251f5aef1c4e7b56324096a /PKGBUILD
downloadaur-bc8c9bc5f3e1b3adea8731d81f3b32fea3c45f82.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0829fcfd226b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+
+pkgname=(python-numba-git)
+_gitname=numba
+pkgver=0.22.1.r574.g77d6a60
+pkgrel=1
+pkgdesc="A lightweight LLVM python binding for writing JIT compilers"
+url="https://github.com/numba/numba"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('python' 'python-llvmlite-git' )
+makedepends=('git' 'cython')
+conflicts=()
+replaces=()
+backup=()
+provides=(python-numba)
+source=(${_gitname}::git+https://github.com/numba/numba.git)
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd numba
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/numba"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/numba"
+ python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+}