summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDylan Delgado2021-12-17 22:05:06 -0500
committerDylan Delgado2021-12-17 22:05:06 -0500
commitb4e50c52f7ea77ab709d8aed45bf913bb5a08b63 (patch)
tree2058d1b7b9ecef4c086f56e5d2a9a522892f5bb2 /PKGBUILD
parent0541723cca54b2fbf950897b4de3967c1f7fea5a (diff)
downloadaur-b4e50c52f7ea77ab709d8aed45bf913bb5a08b63.tar.gz
Rebuild for Python 3.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 126e61fcb9d9..183fb572760a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=python-numpy-git
_pkgname=numpy
-pkgver=v1.21.0.dev0.r814.g740a8cf8c1
-pkgrel=2
+pkgver=v1.23.0.dev0.r229.g0302205105
+pkgrel=1
pkgdesc="Scientific tools for Python - git version"
arch=('x86_64')
license=('custom:BSD 3-clause')
@@ -25,19 +25,20 @@ pkgver() {
prepare() {
# https://github.com/numpy/numpy/issues/17390
- sed -i '/error/a \ ignore:Module already imported so cannot be rewritten' ${srcdir}/numpy/pytest.ini
+ sed -i '/error/a \ ignore:Module already imported so cannot be rewritten' ${srcdir}/numpy/pytest.ini
}
build() {
- cd ${srcdir}/numpy
- python setup.py build
+ cd ${srcdir}/numpy
+ git submodule update --init
+ python setup.py build
}
check() {
cd ${srcdir}/numpy
python setup.py install --root="$PWD/tmp_install" --optimize=1
cd "$PWD/tmp_install"
- PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/python3.9/site-packages/:$PYTHONPATH" python -c 'import numpy; numpy.test()'
+ PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/python3.10/site-packages/:$PYTHONPATH" python -c 'import numpy; numpy.test()'
}
package() {
@@ -46,4 +47,4 @@ package() {
install -m755 -d "${pkgdir}/usr/share/licenses/python-numpy"
install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-numpy/"
-} \ No newline at end of file
+}