summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2020-01-12 17:48:54 +0000
committerGrey Christoforo2020-01-12 17:48:54 +0000
commit7a05a023186c0986ecb5b772c1da0e4bb9abf1b8 (patch)
tree42618c7551abd25882872eb31e27793b4d1a82ed /PKGBUILD
parenta1b8f410cfaa1083ce54474e9569d184e8006f8d (diff)
downloadaur-7a05a023186c0986ecb5b772c1da0e4bb9abf1b8.tar.gz
bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0eace45c543..1ccb2079988e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-objection
-pkgver=1.8.2
+pkgver=1.8.3
pkgrel=1
pkgdesc="runtime mobile exploration"
arch=('any')
url=https://github.com/sensepost/objection
license=('GPLv3')
-depends=(python python-flask python-click python-frida python-frida-tools python-tabulate python-prompt_toolkit python-delegator nodejs)
+depends=(python python-flask python-click python-frida python-frida-tools python-tabulate python-prompt_toolkit python-delegator nodejs litecli)
makedepends=('python-setuptools')
source=(https://github.com/sensepost/objection/archive/${pkgver}.tar.gz)
-sha256sums=('e32e97e98401bb4708918f752d40009ee2de80444e5ec9297d099e853375dcf1')
+sha256sums=('cefe206ab0479b06c4ff3a88476f9756c3bafdf47af3ff1c73f812b7d5429944')
prepare() {
cd "$srcdir/objection-$pkgver/"
@@ -25,6 +25,11 @@ build() {
npm install
}
+check() {
+ cd "$srcdir/objection-$pkgver/"
+ python -m unittest
+}
+
package() {
cd "$srcdir/objection-$pkgver/"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build