summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-10-11 00:11:57 +0100
committerGrey Christoforo2019-10-11 00:11:57 +0100
commite84d5df51728eaef67845bb8d074f321a45875a8 (patch)
tree76ece77850e5276f1e8a1d76ac0f06fe37825fd1 /PKGBUILD
downloadaur-e84d5df51728eaef67845bb8d074f321a45875a8.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95d9f13149df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-objection
+pkgver=1.7.5
+pkgrel=1
+pkgdesc="runtime mobile exploration"
+arch=('any')
+url=https://github.com/sensepost/objection
+license=('GPLv3')
+depends=(python python-flask python-click python-frida python-frida-tools python-tabulate python-prompt_toolkit)
+makedepends=('python-setuptools')
+source=(https://github.com/sensepost/objection/archive/${pkgver}.tar.gz)
+sha256sums=('f3caee908f98e3ed2fe5c4e1555c2a85e371aadde8d273b033f5bcbd52617419')
+
+prepare() {
+ cd "$srcdir/objection-$pkgver/"
+ #versioneer install
+}
+
+build() {
+ cd "$srcdir/objection-$pkgver/"
+ python setup.py build
+}
+
+
+package() {
+ cd "$srcdir/objection-$pkgver/"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+
+# vim:ts=2:sw=2:et: