summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-07-05 15:00:43 +0430
committerMohammadreza Abdollahzadeh2022-07-05 15:00:43 +0430
commit0946a9807637ed08587628e140641b618bf0a8e5 (patch)
tree07a9154c0198daea0f62e92b7a6dc185f683e2d3 /PKGBUILD
parent4947f020b429d3366656070b65e2dbca0ccf6d10 (diff)
downloadaur-0946a9807637ed08587628e140641b618bf0a8e5.tar.gz
update to 1.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fecc5c669248..edb4ef2ef680 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=python-obspy-docs
-pkgver=1.2.0
+pkgver=1.3.0
pkgrel=1
pkgdesc='Set of HTML documentation for Obspy seismological framework.'
arch=('any')
url='http://docs.obspy.org'
license=('LGPL')
options=('docs')
-source=(http://docs.obspy.org/archive/obspy-${pkgver}-documentation.tgz)
-sha256sums=('aacb0b14f0c9955f5592b7858ea455e1d02d91fab3ba7f74f11b800daeb681a9')
+makedepends=('python-cartopy' 'python-obspy' 'python-m2r2' 'python-matplotlib' 'python-sphinx' 'python-sphinx_rtd_theme')
+source=("${pkgname%-docs}-${pkgver}.tar.gz::https://github.com/obspy/obspy/archive/${pkgver}.tar.gz")
+sha256sums=('12a5ba9cae3445c9f31bd0e0561e791bc755cc627d4412f851f6286fef82be34')
+
+build() {
+ cd "obspy-${pkgver}/misc/docs"
+ mkdir _build
+ sphinx-build -a -E -j auto -b html source _build
+}
package() {
+ cd "obspy-${pkgver}/misc/docs"
install -d ${pkgdir}/usr/share/doc/python-obspy
- cp -a obspy-${pkgver}-documentation ${pkgdir}/usr/share/doc/python-obspy/html
+ cp -a _build ${pkgdir}/usr/share/doc/python-obspy/html
}
# vim:set ts=4 sw=4 et: