summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2021-03-28 17:26:51 +0200
committerGrey Christoforo2021-03-28 17:26:51 +0200
commit2cf9f1f96d362362767198d484af92e3ae90a017 (patch)
tree4ca5202d3bb5c7861fb5cf3a80409486005aba40 /PKGBUILD
parente2241c58933cc0b412f2272f569fc901e7960ffe (diff)
downloadaur-2cf9f1f96d362362767198d484af92e3ae90a017.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2545a41ef073..629acd4ba698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,13 +57,18 @@ build() {
cd OCP
# get symbols
- mkdir -p dummy/lib_linux/
+ local _structure_needed="dummy/lib_linux/"
+ mkdir -p ${_structure_needed}
ln -s /usr/lib dummy/lib_linux/.
+ msg2 "Old symbols:"
+ ls -lh *.dat
rm *.dat
msg2 "Dumping symbols..."
python dump_symbols.py dummy
- msg2 "Dump complete."
- ls -lh symbols_mangled_linux.dat
+ msg2 "Dump complete. New symbols:"
+ ls -lh *.dat
+ rm -rf ${_structure_needed}
+ find -maxdepth 1 -name '*.dat' -exec ln -sf ../{} pywrap/{} \;
CONDA_PREFIX=/usr PYTHONPATH=pywrap python -m bindgen \
--clean \
@@ -72,24 +77,19 @@ build() {
--include "/usr/include/vtk" \
all ocp.toml
- cmake \
- -W no-dev \
- -D CMAKE_INSTALL_PREFIX="/usr" \
+ cmake -B build_dir -S OCP -W no-dev -G Ninja \
-D OPENCASCADE_INCLUDE_DIR=opencascade \
+ -D CMAKE_INSTALL_PREFIX="/usr" \
-D CMAKE_BUILD_TYPE=None \
- -D CMAKE_CXX_FLAGS="-DVTK_MAJOR_VERSION=9" \
- -B build_dir \
- -G Ninja \
- -S OCP
+ -D CMAKE_CXX_FLAGS="-DVTK_MAJOR_VERSION=9"
cmake --build build_dir
}
check() {
cd OCP
- cd build_dir
#python -c "from OCP.gp import gp_Vec, gp_Ax1, gp_Ax3, gp_Pnt, gp_Dir, gp_Trsf, gp_GTrsf, gp, gp_XYZ"
- python -c "import OCP"
+ PYTHONPATH="./build_dir" python -c "import OCP"
}
package(){