summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreyson Christoforo2021-11-03 15:35:51 +0000
committerGreyson Christoforo2021-11-03 15:35:51 +0000
commit9b3f92b9f2ff68efd3ebd77a8aa6a612ab9c058a (patch)
tree2c59ad0153d6da1d688fe7b81dae4fd040886dfb /PKGBUILD
parentb5f42cd89ffe865d323fd595cfeab82297f6cdcc (diff)
downloadaur-9b3f92b9f2ff68efd3ebd77a8aa6a612ab9c058a.tar.gz
change deps to use distro packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 969e9ef91720..b9e17a8eda2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-ocp-git
-pkgver=7.5.RC2.r1.gb058865
+pkgver=7.5.2.beta.r2.g52c15d8
pkgrel=1
pkgdesc="Python wrapper for OCCT generated using pywrap"
arch=(x86_64)
@@ -9,8 +9,8 @@ url=https://github.com/CadQuery/OCP
license=('Apache')
depends=(
python
-opencascade-rc
-vtk9-java
+opencascade
+vtk
)
makedepends=(
git
@@ -46,8 +46,9 @@ prepare(){
cd OCP
git submodule update --init --recursive
- # opencascade is 7.5.2 not 7.5.1
- sed 's,7.5.1,7.5.2,g' -i dump_symbols.py
+ # opencascade is 7.5.3 not 7.5.1
+ # TODO: unhardcode this crap
+ sed 's,7.5.1,7.5.3,g' -i dump_symbols.py
# don't use the opencascade headers packaged here
# instead use the ones from the installed opencascade package