summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGreyson Christoforo2021-01-16 13:52:10 +0000
committerGreyson Christoforo2021-01-16 13:52:10 +0000
commitdf219d9ecbb635b082c4f4367b1236d3dd9f51a4 (patch)
treef3ea3ef33d4ffc9a22e5c387f44ea69b886d8164 /PKGBUILD
parent265710194686b2133c72233f6df5c6ca0a80bb29 (diff)
downloadaur-df219d9ecbb635b082c4f4367b1236d3dd9f51a4.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdb9b8db773a..15a686eb3f3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,7 +52,7 @@ prepare(){
build() {
cd OCP
- PYTHONPATH=pywrap python -m bindgen \
+ CONDA_PREFIX=/usr PYTHONPATH=pywrap python -m bindgen \
--clean \
--libclang "$(ldconfig -p | grep 'libclang.so$' | awk '{print $NF}')" \
--include "$(clang -print-resource-dir)"/include \
@@ -63,25 +63,27 @@ build() {
-D CMAKE_INSTALL_PREFIX="/usr" \
-D OPENCASCADE_INCLUDE_DIR=opencascade \
-D CMAKE_BUILD_TYPE=None \
- -B "${srcdir}/build" \
+ -B build_dir \
-G Ninja \
-S OCP
- ninja -C "${srcdir}/build"
+ cmake --build build_dir
}
check() {
- cd "${srcdir}/build"
+ cd OCP
+ cd build_dir
python -c "from OCP.gp import gp_Vec, gp_Ax1, gp_Ax3, gp_Pnt, gp_Dir, gp_Trsf, gp_GTrsf, gp, gp_XYZ"
}
package(){
cd OCP
- _python_site_path="$(python -c 'import sys; print(sys.path[-1])')"
- mkdir -p "${pkgdir}/${_python_site_path}"
- cp "${srcdir}"/build/OCP.*.so "${pkgdir}/${_python_site_path}"
+ #_python_site_path="$(python -c 'import sys; print(sys.path[-1])')"
+ #mkdir -p "${pkgdir}/${_python_site_path}"
+ #cp "${srcdir}"/build/OCP.*.so "${pkgdir}/${_python_site_path}"
- install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE
+ install -Dt "${pkgdir}$(python -c 'import sys; print(sys.path[-1])')" -m644 build_dir/OCP.*.so
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE
}
# vim:ts=2:sw=2:et: